dell ftos 03a physical interface configuration

9
Interface Configuration Module 3A - Physical Interface 3A-2 Objectives Identify Interface Types Define Physical Interfaces L2 ports L3ports Management Define Logical Interfaces Loopback Null Port-Channel VLANs Utilize show interface commands Familiarize with the Management Route Table Discuss Loopback Interfaces

Upload: bambang-adi

Post on 10-Dec-2015

26 views

Category:

Documents


1 download

DESCRIPTION

Ftos

TRANSCRIPT

Page 1: Dell FTOS 03a Physical Interface Configuration

Interface Configuration

Module 3A - Physical Interface

3A-2

Objectives • Identify Interface Types

• Define Physical Interfaces

• L2 ports

• L3ports

• Management

• Define Logical Interfaces

• Loopback

• Null

• Port-Channel

• VLANs

• Utilize show interface commands

• Familiarize with the Management Route Table

• Discuss Loopback Interfaces

Page 2: Dell FTOS 03a Physical Interface Configuration

3A-3

Interface Types

Interface Type Modes

Possible Default Mode

Require Creation

Default State

Physical 1-Gigabit Ethernet, 10-Gigabit Ethernet

interfaces, and SONET interfaces L2, L3 Unset No

Shutdown (disabled)

Management Located on the RPM and provides

management access N/A N/A No

Shutdown (disabled)

Loopback Virtual interface in which the software

emulates a physical interface L3 L3 Yes

No Shutdown (enabled)

Null Virtual interface that is always up, but no

traffic flows on this interface N/A N/A No Enabled

Port Channel Virtual interface that provides redundancy

by allowing the aggregation of up to 16 physical interfaces

L2, L3 Unset Yes Shutdown (disabled)

VLAN Logical interfaces to separate broadcast

domains L2, L3 L2

Yes (except Default)

Shutdown (L2 Forwarding enabled L3 Forwarding disabled)

3A-4

Interface Configuration Mode

• To configure a specific interface, enter the interface sub-mode: – Force10(conf)# interface {interface} slot/port where the interface is:

• fastethernet • gigabitethernet • tengigabitethernet • fortygigabitethernet • interface-group • loopback • managementethernet • null • port-channel • sonet • vlan • range

EXEC

EXEC (Privileged)

CONFIGURATION

Interface

FastEthernet

GigabitEthernet

TenGigabitEthernet

ManagementEthernet

Loopback

VLAN

…(others not listed)

Protocol <L2 Protocol>

FVRP

Spanning-Tree

Router <L3 Protocol>

RIP

OSPF

BGP

ISIS

…(others not listed)

Page 3: Dell FTOS 03a Physical Interface Configuration

3A-5

Physical Interfaces

• Refers to physical ports that are on Line Cards

• Configured through Interface sub-mode – In this mode, any commands entered will be applied to only the interface(s)

listed at the prompt

Interface Type Modes

Possible Default Mode

Require Creation

Default State

Physical 1-Gigabit Ethernet, 10-Gigabit

Ethernet interfaces, and SONET interfaces

L2, L3 Unset No Shutdown (disabled)

3A-6

Force10(conf-if-gi-5/1)#show config

!

interface GigabitEthernet 5/1

ip address 10.1.1.1 /24

no shutdown

Force10(conf-if-gi-5/1)#

Force10(conf-if-gi-5/1)# no ip address

Force10(conf-if-gi-5/1)# switchport

Force10(conf-if-gi-5/1)# show config

!

interface GigabitEthernet 5/1

no ip address

switchport

no shutdown

Force10(conf-if-gi-5/1)#

Configuring An Interface for Layer 2 Mode

A.Use show config to view interface configuration

B.Ensure that the interface’s configuration does not contain an IP address 1.Enter no ip address to

remove IP address

C.Enter the switchport command to change to L2 Mode

D.“switchport” in show conf display denotes the interface is in L2 mode

A

B1

C

D

Page 4: Dell FTOS 03a Physical Interface Configuration

3A-7

Force10# show int gi 5/1

GigabitEthernet 5/1 is up, line protocol is down

Hardware is Force10Eth, address is 00:01:e8:0b:5e:0d

Internet address is 10.1.1.1/24

MTU 1554 bytes, IP MTU 1500 bytes

LineSpeed auto, Mode full duplex

ARP type: ARPA, ARP Timeout 04:00:00

Last clearing of "show interface" counters 00:41:11

Queueing strategy: fifo

0 packets input, 0 bytes

Input 0 Vlans

0 64-byte pkts, 0 over 64-byte pkts, 0 over 127-

byte pkts

0 over 255-byte pkts, 0 over 511-byte pkts, 0

over 1023-byte pkts

Received 0 runts, 0 giants, 0 throttles

0 CRC, 0 overrun, 0 discarded

4 packets output, 256 bytes, 0 underruns

Output 0 Multicasts, 4 Broadcasts, 0 Unicasts

0 Vlans, 0 throttles, 0 discarded

Rate info (interval 299 seconds):

Input 00.00 Mbits/sec, 0 packets/sec,

0.00% of line-rate

Output 00.00 Mbits/sec, 0 packets/sec,

0.00% of line-rate

Time since last interface status change: 00:40:38

Force10#

Viewing Interface Information

Force10# show interface

gi 5/1

– GigabitEthernet 5/1 is up, line protocol is down

– Interface up/down status – The interface has been

enabled administratively, but there is no data path through the MAC.

3A-8

Configuring An Interface for Layer 3 Mode

• Configuring IP Addresses puts the interface in Layer 3 mode

Force10(conf-if-gi-x/y)#ip address <ip-address> /<mask>

– IP address must be in dotted decimal format

– Mask value must be in /prefix-length format (/24)

• Remember to type no shutdown to enable the interface

Force10(conf-if-gi-5/1)#show conf

!

interface GigabitEthernet 5/1

ip address 10.1.1.1/24

no shutdown

Force10(conf-if-gi-5/1)#

Page 5: Dell FTOS 03a Physical Interface Configuration

3A-9

• Use the interface range command to configure multiple ports simultaneously Force10(conf)# interface range {interface} slot/{port {–|,}

port}

– Use a hyphen (-) to specify contiguous ports – Use a comma (,) to specify non-contiguous ports

Force10(conf)#

Force10(conf)# interface range gig 5/1 – 5 (ports in sequence) Force10(conf-if-range-gi-5/1-5)# exit

Force10(conf)#

Force10(conf)# interface range gig 5/1 , gig 5/3 , gig 5/20 (non-contiguous) Force10(conf-if-range-gi-5/1,gi-5/3,gi-5/20)#exit

Force10(conf)#

Simultaneously Configuring More Than One Interface

NOTE: Correct syntax needs spaces before and after the comma or hyphen.

3A-10

• If an interface range definition will be used many times, a macro can be defined to represent the interface range – Force10(conf)# define interface-range {name}

GigabitEthernet slot/{port {–|,} port}

• To apply the macro, use the same command as the interface range, but specify a macro instead – Force10(conf)# interface range macro {name}

Force10(conf)#

Force10(conf)#define interface-range DMZ_ports gig 5/1 – 5

Force10(conf)#int range macro DMZ_ports

Force10(conf-if-range-gi-5/1-5)#exit

Force10(conf)#exit

Force10#show running-config | grep range

define interface-range DMZ_ports gigabitethernet 5/1 - 5

Force10#

Interface Range Macro

Page 6: Dell FTOS 03a Physical Interface Configuration

3A-11

Other Show Interface Commands

Force10# show ip interfaces brief configured

– shows a list of interfaces that are not in default state

Force10# show interfaces linecard <#>

– shows all interfaces on a given linecard

Force10# show interfaces switchport

– shows 802.1QTagged status and VLAN membership

Force10# show interfaces vlan <vlan-id>

– similar to show interface, but per VLAN

Force10# show ip interfaces brief

– shows ip configurations in one-line table

Force10# clear counters interface <slot/port>

– clears show interface counters, doesn’t clear SNMP counters

3A-12

Out of Band Management Interface

• “Management 0/0” on RPM0

• “Management 1/0” on RPM1

• Physically located on all RPMs and newer S-Series (55/60/4810)

– E-Series 10/100 BaseT

– Z/S/C-Series 10/100/1000 BaseT

• IP Address overlap not permitted

• Configured like physical interfaces with some limitations

– Cannot configure a gateway address or an IP address that appears in the main routing table

• Separate Routing Table

RPMs

0 & 1

Page 7: Dell FTOS 03a Physical Interface Configuration

3A-13

Management Interface Route Table (RIB)

• If there is a management route configured for the source network (or host)… – Any traffic received on Ma0/0 will only route back through this same

interface

– The main routing table is not referenced but has implications for any static routes created for the management interface

• Use the management route command – (instead of the ip route command)

• More specific routes must exist in the management route table (show ip management-route) to make these static routing entries "active“

– Any same or less specific routes in the main route table (show ip route) will make the management RIB entries state "inactive“

This is demonstrated on the next slide with the default routes

3A-14

Force10(conf)#do sh run int ma0/0 ! interface ManagementEthernet 0/0 ip address 172.16.1.181/24 no shutdown

Force10(conf)#management route 10.11.4.0/24 172.16.1.250

Force10(conf)#do sh ip management-route all

Force10#sh ip management-route all Destination Gateway State ----------- ------- ----- 10.11.4.0/24 172.16.1.250 Active 172.16.1.0/24 ManagementEthernet 0/0 Connected 0.0.0.0/0 172.16.1.250 Inactive

Force10#sh ip route Codes: C - connected, S - static, R - RIP B - BGP, IN - internal BGP, EX - external BGP, LO - Locally Originated O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1 N2 - OSPF NSSA external type 2, E1 - OSPF external type 1 E2 - OSPF external type 2, i - IS-IS, L1 - IS-IS level-1 L2 - IS-IS level-2, IA - IS-IS inter area, * - candidate default - non-active route + - summary route

Gateway of last resort is 1.2.3.4 to network 0.0.0.0

Destination Gateway Dist/Metric Last Change ----------- ------- ----------- ----------- *S 0.0.0.0/0 via 1.2.3.4, Po 1 1/0 00:00:06 C 10.0.0.0/24 Direct, Gi 0/0 0/0 1d19h C 34.94.168.0/21 Direct, Vl 12 0/0 2d17h C 92.68.251.0/24 Direct, Gi 0/10 0/0 2d17h

Management Route Table Example

A. A host with an IP address (10.11.4.18) can telnet to the Ma0/0 interface (172.16.1.181)

B. …because a management route to the 10.11.4.0/24 subnet was configured

C. …using the default gateway, 172.16.1.250, of the management network

D. The configured default management route 0.0.0.0/0 via 172.16.1.250 is inactive

E. …because it exists in the main system route table

B

C

D

E

A

Page 8: Dell FTOS 03a Physical Interface Configuration

3A-15

A

B

C

A. Configure the IP address for the Management Ethernet interface(s)

B. Enable the interface using the command “no shutdown”

C. Configure static routes to networks that will have management hosts

D. Verify static management routes are active using the command “show ip management-route all”

Steps to Configure a Management Interface

R2(conf)#interface managementethernet 0/0

R2(conf-if-ma-0/0)#ip add 10.11.80.201/24

R2(conf-if-ma-0/0)#no shutdown

R2(conf-if-ma-0/0)#show config

!

interface ManagementEthernet 0/0

ip address 10.11.80.201/24

no shutdown

R2(conf-if-ma-0/0)#

R2(conf)#management route 145.8.10.0/24 10.11.80.254

R2(conf)#management route 10.12.200.0/24

10.11.80.254

R2(conf)#do show ip management-route all

Destination Gateway State

----------- ------- -----

10.11.80.0/24 ManagementEthernet 0/0 Connected

10.12.200.0/24 10.11.80.254 Active

34.0.0.0/8 10.11.80.254 Inactive

145.8.10.0/24 10.11.80.254 Active

D

3A-16

• Virtual interface in which the software emulates an interface – Many of the same L3 commands as the physical interfaces

• Create Loopback interface: Force10(conf)# interface loopback number

Force10(conf)#int loop 0

Force10(conf-if-lo-0)#ip address 1.1.1.1/32

Force10(conf-if-lo-0)#show conf

!

interface Loopback 0

ip address 1.1.1.1/32

no shutdown

Force10(conf-if-lo-0)#

Loopback Interfaces

Page 9: Dell FTOS 03a Physical Interface Configuration

3A-17

• Virtual interface created by FTOS software

• “Blackhole” unwanted traffic instead of using Access Lists

• Only one Null interface

• Null interface always up, but no traffic flows on this interface

• Only configurable command

Force10(conf-if-nu-0)# ip unreachable

– Enables ICMP unreachable messages

Null 0 Interface Force10(conf)# interface null 0

Force10(conf-if-nu-0)#ip unreachables

Force10(conf-if-nu-0)#show conf

!

interface null 0

ip unreachables

Force10# show int null 0

NULL 0 is up, line protocol is up

Hardware is unknown.

Interface index is 1107705856

LineSpeed auto

ARP type: ARPA, ARP Timeout 04:00:00

Last clearing of "show interface" counters 6d4h24m

Queueing strategy: fifo

Input Statistics:

0 packets, 0 bytes

0 IP Packets, 0 Vlans, 0 MPLS

0 64-byte pkts, 0 over 64-byte pkts, 0 over 127-byte pkts

0 over 255-byte pkts, 0 over 511-byte pkts, 0 over 1023-

byte pkts

0 Multicasts, 0 Broadcasts

0 symbol errors, 0 runts, 0 giants, 0 throttles

0 CRC, 0 IP Checksum, 0 overrun, 0 discarded

Output Statistics:

0 packets, 0 bytes, 0 underruns

0 64-byte pkts, 0 over 64-byte pkts, 0 over 127-byte pkts

0 over 255-byte pkts, 0 over 511-byte pkts, 0 over 1023-

byte pkts

0 Multicasts, 0 Broadcasts, 0 Unicasts

0 IP Packets, 0 Vlans, 0 MPLS

0 throttles, 0 discarded

Time since last interface status change: 6d4h24m

3A-18

Summary In this module we covered:

• Interface Types

• Physical Interfaces

• L2 ports

• L3ports

• Management

• Logical Interfaces

• Loopback

• Null

• Port-Channel

• VLANs

• show interface commands

• Management Route Table

• Loopback Interfaces