algoritmos – aula 3 operadores relacionais, lógicos e comandos de condição

Download ALGORITMOS – AULA 3 Operadores Relacionais, Lógicos e comandos de condição

Post on 18-Apr-2015

105 views

Category:

Documents

3 download

Embed Size (px)

TRANSCRIPT

  • Slide 1
  • ALGORITMOS AULA 3 Operadores Relacionais, Lgicos e comandos de condio
  • Slide 2
  • Expresses Lgicas Denomina-se expresso lgica aquela cujos operadores so lgicos e/ou relacionais e cujos operandos so relaes e/ou variveis e/ou constantes do tipo lgico. operando lgicooperador lgico constante lgica varivel lgica expresso relacional no expresso lgica operando lgico
  • Slide 3
  • Operadores Relacionais Os operadores relacionais so utilizados para realizar comparaes entre dois valores (constantes, variveis ou expresses aritmticas) de mesmo tipo primitivo. O resultado obtido de uma expresso relacional sempre um valor lgico.
  • Slide 4
  • Operadores Lgicos Os operadores lgicos mais utilizados so:
  • Slide 5
  • Comando de Atribuio Permite-nos fornecer um valor a uma certa varivel, onde o tipo dessa informao deve ser compatvel com o tipo da varivel. O comando da atribuio possui a seguinte sintaxe: identificadorexpresso ; expresso aritmtica expresso lgica atribuio expresso Exemplo: lgico: A, B; inteiro: X; A verdadeiro; X 8 + 13 div 5; B 5 = 3;
  • Slide 6
  • Comandos de Entrada e Sada Sintaxe do comando da entrada de dados: entrada de dados leia varivel (), ; Exemplos: leia (X); leia (A, XPTO, NOTA);
  • Slide 7
  • Sada de Dados Sintaxe do comando da sada de dados: sada de dados escreva varivel (), ; Exemplos: escreva (Y); escreva (B, XPTO, MEDIA); escreva (Bom Dia , NOME); escreva (Voc pesa , X*2, quilos.); constante expresso
  • Slide 8
  • Blocos Um bloco definido como um conjunto de aes com uma funo definida. Algoritmo seria um bloco !? Serve tambm para definir os limites nos quais as variveis declaradas em seu interior so conhecidos. Para delimitar um bloco, utiliza-se os delimitadores: inicio e fim, como segue: blocos inicioaofim;,
  • Slide 9
  • Exemplo de Bloco inicio {incio do bloco (algoritmo)} | |{declarao de variveis} |{seqncia de aes} | fim. {bloco (algoritmo)}
  • Slide 10
  • Estrutura Sequencial O Fluxo de Controle segue a mesma sequncia linear da nossa escrita, ou seja: De cima para baixo; Da esquerda para direita Cada ao seguida de um ; Objetiva separar uma ao da outra Indica que a prxima ao da sequncia deve ser executada
  • Slide 11
  • Estrutura sequencial incio // declarao de variveis // corpo do algoritmo ao 1; ao 2; ao 3;. ao n; fim. // fim do algoritmo Algoritmo 3.1 Modelo geral
  • Slide 12
  • Estrutura sequencial incio // declarao de variveis real: N1, N2, N3, N4, // notas bimestrais MA; // mdia anual // entrada de dados leia (N1, N2, N3, N4); // processamento MA (N1 + N2 + N3 + N4) / 4; // sada de dados escreva (MA); fim. Algoritmo 3.2 - Mdia Aritmtica
  • Slide 13
  • Estruturas de Seleo So aquelas que permitem alterar o Fluxo de Execuo, de forma a selecionar qual parte deve ser executada Essa deciso de execuo tomada a partir de uma condio, que pode resultar apenas em Verdade ou Falsidade Uma condio representada por expresses relacionais ou lgicas As estruturas de seleo podem ser classificadas em simples, compostas ou encadeadas
  • Slide 14
  • Seleo Simples Quando a for verdadeira o bloco verdade executado Quando a for falsa o bloco verdade no executado se ento incio // incio do bloco verdade comando 1; comando 2;... comando n; fim; // fim do bloco verdade fimse;
  • Slide 15
  • Seleo Simples incio // declarao de variveis real: N1, N2, N3, N4, // notas bimestrais MA; // mdia anual // entrada de dados leia (N1, N2, N3, N4); // processamento MA (N1 + N2 + N3 + N4) / 4; // sada de dados escreva (MA); se (MA >= 7) ento escreva (Aluno Aprovado !); fimse; fim. Algoritmo 3.3 - Mdia Aritmtica com Aprovao
  • Slide 16
  • Seleo Composta Quando a for verdadeira o bloco verdade executado Quando a for falsa o bloco falsidade executado se ento incio // incio do bloco verdade comando 1; comando n; fim; // fim do bloco verdade seno incio // incio do bloco falsidade comando 1; comando n; fim; // fim do bloco falsidade fimse;
  • Slide 17
  • Seleo Composta incio // declarao de variveis real: N1, N2, N3, N4, // notas bimestrais MA; // mdia anual leia (N1, N2, N3, N4); MA (N1 + N2 + N3 + N4) / 4; escreva (MA); se (MA >= 7) ento incio escreva (Aluno Aprovado !); escreva (Parabns !); fim; seno incio escreva (Aluno Reprovado !); escreva (Estude mais !); fim; fimse; fim. Algoritmo 3.4 - Mdia Aritmtica com aprovao e reprovao
  • Slide 18
  • Seleo Encadeada Ocorre quando uma seleo tem como ao uma outra seleo Uma seleo encadeada pode ser: Heterognea: Quando no possvel identificar padro de comportamento Homognea: Quando possvel identificar padro de comportamento se ento se: quando depois de cada ento ocorre outro se se seno se: quando depois de cada seno ocorre outro se
  • Slide 19
  • Seleo Encadeada Dados trs valores A, B, C, verificar se eles podem ser os comprimentos dos lados de um tringulo Caso positivo, verificar se compem Tringulo equiltero Tringulo issceles Tringulo escaleno A B C
  • Slide 20
  • Seleo Encadeada Dados trs valores A, B, C, verificar se eles podem ser os comprimentos dos lados de um tringulo Caso positivo, verificar se compem Tringulo equiltero trs lados iguais Tringulo issceles dois lados iguais Tringulo escaleno todos os lados diferentes A B C
  • Slide 21
  • Seleo Encadeada Tringulo: (A