Обзор технологии fabric path

70
© 2011 Cisco and/or its affiliates. All rights reserved. 1 Обзор технологии Fabric Path Александр Блусенков Инженер центра технической поддержки Cisco TAC в Брюсселе Декабрь 2013 Cisco Support Community Expert Series Webcasts in Russian

Upload: cisco-russia

Post on 25-Dec-2014

626 views

Category:

Technology


8 download

DESCRIPTION

 

TRANSCRIPT

Page 1: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 1

Обзор технологии Fabric Path

Александр Блусенков

Инженер центра технической поддержки Cisco TAC в Брюсселе

Декабрь 2013

Cisco Support Community Expert

Series Webcasts in Russian

Page 2: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 2

Сегодня на семинаре эксперт Cisco TAC Александр Блусенков расскажет расскажет о технологии FabricPath, ее концепции и характеристиках.

Александр Блусенков

Инженер центра технической

поддержки Cisco TAC в Брюсселе

2

Expert’s photo

Page 3: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 3

Сегодняшняя презентация включает опросы аудитории

Пожалуйста, участвуйте!

Page 4: Обзор технологии Fabric Path

4 © 2011 Cisco and/or its affiliates. All rights reserved.

https://supportforums.cisco.com/docs/DOC-38680

Page 5: Обзор технологии Fabric Path

5 © 2011 Cisco and/or its affiliates. All rights reserved.

Используйте Q&A панель, чтобы послать вопрос. Наши эксперты ответят на них

Page 6: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 6

a) Нет, не имел(а) опыта и хочу ознакомится с технологией в целом

b) Нет, не имел(а) опыта, но мы рассматриваем возможность внедрение в будущем

c) Я занимаюсь дизайном сетей и рассматриваю FabricPath как один из возможных вариантов

d) Я занимаюсь активной поддержкой собственной/клиентской FabricPath сети

Имеете ли вы опыт работы с FabricPath в дата центрах?

Page 7: Обзор технологии Fabric Path

7 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – Терминология и

основные понятия

Page 8: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 8

• IS-ISавтоматически назначает адреса всем FabricPath

устройствам

• Просчитывает оптимальный (кратчайший) маршрут

• Поддерживает балансировку нагрузки внутри FabricPath

облака

Plug-n-Play L2 IS-IS «управляет» облаком

L1 L2 L3

L4

FabricPath облако

S100 S200 S300 S400

S10 S20 S30 S40

Page 9: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 9

Классический Ethernet (CE)

S10 S20 S30 S40

S100 S200 S300

1/1 S300: CE таблица

MAC адресов

MAC IF

B 1/2

… …

MAC IF

B 1/2

A S100

1/2

S300: FabricPath

Таблица мар-ции

Switch IF

… …

S100 L1, L2, L3, L4

FabricPath (FP)

Switch ID:

Решение

принимается на

основании FP

таблицы

маршрутизации

MAC address space:

Классическая схема

коммутации на

основе MAC адреса

• Пограничные устройства содержат таблицу MAC-SwitchID

Трафик инкапсулируется при передачи внутри облака FP

S100 S300 A B

A B

Page 10: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 10

CE Edge порты

FP Core порты

Spine Switch

Leaf Switch

Интерфейсы включенные в классическую сеть

Трафик - 802.3 Ethernet трафик

STP

Коммутация на основе MAC таблицы

Classical Ethernet (CE)

S10 S20 S30 S40

S100 S200 S300

1/1 1/2

FabricPath (FP)

A B

Точка подключения к другому FabricPath устройству

Обрабатывает трафик с FabricPath заголовком

FP облако не полагается на STP

Топологическая информация рассылается в рамках L2 ISIS

Коммутация трафика на основе‘Switch ID Table’

Page 11: Обзор технологии Fabric Path

11 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – одноадресная

передача (aka Unicast Forwarding)

Page 12: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 12

S100

S10 S20 S30 S40

S200 S300 FabricPath

• Кратчайший маршрут для каждого Switch ID

• Equal-cost paths поддерживается между FabricPath коммутаторами

FabricPath

табл. марш-и на S100

Switch IF

S10 L1

S20 L2

S30 L3

S40 L4

S200 L1, L2, L3, L4

… …

S300 L1, L2, L3, L4

Один «лучший» путь

к S10 (через L1)

4 равнозначных

пути к S300

Page 13: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 13

• Для ISIS, как и для любых протоколов возможны микро-путли в момент конвергенции

• Для снижения негативного эффекта, ISIS использует аналог TTL IP:

"hop-count" равен 32

• Немного иные методы имеют место для multidestination tree:

Коммутация ТОЛЬКО на основе FTAG, но не SwitchID как для unicast fwd.

Аналог RPF происходит на каждом устройстве – Source SwitchID для конкретного FTAG должен должен быть «за интерфейсом», на котором получили фрейм:

show fabricpath isis trees multidestination [1 | 2]

Page 14: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 14

S100# sh fabricpath isis route

Fabricpath IS-IS domain: default MT-0

Topology 0, Tree 0, Swid routing table

10, L1

via port-channel10, metric 20

20, L1

via port-channel20, metric 20

30, L1

via port-channel30, metric 20

40, L1

via port-channel40, metric 20

200, L1

via port-channel30, metric 40

via port-channel40, metric 40

via port-channel20, metric 40

via port-channel10, metric 40

300, L1

via port-channel30, metric 40

via port-channel40, metric 40

via port-channel20, metric 40

via port-channel10, metric 40

S100#

FabricPath

A C B

S100 S300 S200

S10 S20 S30 S40

po10

po20

po30

po40

Switch ID

получателя

Следующий

интерфейс

Метрика

Page 15: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 15

S10 S20 S30 S40

• Для FP топологии строятся два Multidestination дерева

• Корневой коммутатор выбирается для каждого multidestination tree в FabricPath домене

• Беспетлевое дерево строится от каждого корневого коммутатора, иначе говоря для каждого Ftag

Root for

Tree 1

S100 S20

Root for

Tree 2

S10 S200

S300

S30

S40

Logical

Tree 1

Root

S40

S100

S200

S300

S10

S20

S30

Logical

Tree 2

Root

S100 S200 S300 FabricPath

Page 16: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 16

FabricPath Core

• Каждый FP коммутатор строит Switch ID (L2 маршру) таблицу

• Входной FabricPath коммутатор:

По MAC таблице определяется Switch-ID (SID) получателя, sub-Switch ID (sSID), и локальный ID (LID) (иначе выходной интерфейс)

Для данного SID/sSID/LID определяется выходной интерфейс

• Транзитный FabricPath коммутатор:

Для данного SID/sSID/LID определяется выходной интерфейс

• Выходной FabricPath коммутатор:

Для данного SID/sSID/LID определяется выходной порт, пакет декапсулируется и передается как 802.3 Ethernet фрейм

MAC table lookup

SID/sSID/LID lookup

SID/sSID/LID lookup SID/sSID/LID lookup

Page 17: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 17

Cisco FabricPath

фрейм

Классический Ethernet фрейм

• Switch ID – уникальный ID каждого FP коммутатора

• Sub-Switch ID – определяет устройство подключенное по VPC+

• LID – Local ID, identifies the destination or source interface

• Ftag (Forwarding tag) – уникальный идентификатор топологии и/или дерева

DMAC SMAC 802.1Q Etype CRC Payload

DMAC SMAC 802.1Q Etype Payload CRC

(new)

FP

Tag

(32)

Outer

SA

(48)

Outer

DA

(48)

Endnode ID

(5:0)

Endnode ID

(7:6)

U/L

I/G

RS

VD

OO

O/D

L

Etype

0x8903

6 bits 1 1 2 bits 1 1 12 bits 8 bits 16 bits 10 bits 6 bits 16 bits

Switch ID Sub

Switch ID Ftag TTL LID

Original CE Frame 16 bytes

Page 18: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 18

FabricPath

MAC Table on S100

MAC IF/SID MAC IF/SID

A e1/13 (local)

e2/29

S10 S20 S30 S40

Root for

Tree 1

Root for

Tree 2

S100 S200 S300

(1) Broadcast ARP Request

MAC A MAC B

Multidestination

Trees on Switch 100

Tree IF

1 po10

2 po10,po20,po30,po40

Broadcast →

DMAC→FF

SMAC→A

Payload

Multidestination

Trees on Switch 10

Tree IF

1 po100,po200,po300

2 po100

po10 po20

po40

po30

Ftag →

Ftag →

DMAC→FF

SMAC→A

Payload

DA→FF

Ftag→1

SA→100.0.12

DMAC→FF

SMAC→A

Payload

po100

po300

po200

e1/13

po10

po20 po30 po40

1

3

2

4

6

DMAC→FF

SMAC→A

Payload

DA→FF

Ftag→1

SA→100.0.12

Learn MACs of directly-connected

devices unconditionally

Don’t learn MACs from

flood frames

FabricPath

MAC Table on S200

MAC IF/SID

Multidestination

Trees on Switch 300

Tree IF

1 po10,po20,po30,po40

2 po40

5

Page 19: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 19

• S100:

S100# sh mac address-table dynamic

Legend:

* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC

age - seconds since last seen,+ - primary entry using vPC Peer-Link

VLAN MAC Address Type age Secure NTFY Ports/SWID.SSID.LID

---------+-----------------+--------+---------+------+----+------------------

* 10 0000.0000.000a dynamic 90 F F Eth1/13

10 0000.0000.000b dynamic 60 F F 300.0.64

S100#

• S300:

S300# sh mac address-table dynamic

Legend:

* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC

age - seconds since last seen,+ - primary entry using vPC Peer-Link

VLAN MAC Address Type age Secure NTFY Ports/SWID.SSID.LID

---------+-----------------+--------+---------+------+----+------------------

* 10 0000.0000.000b dynamic 0 F F Eth2/29

S300#

S100 learns MAC B as

remote entry reached

through S300

MAC B learned as

local entry on e2/29

Page 20: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 20

e2/29

S10 S20 S30 S40

S200 S300

MAC A MAC B

po10 po20

po40

po30

e1/13

po10

po20 po30 po40

S100

DMAC→B

SMAC→A

Payload

FabricPath

MAC Table on S100

DMAC→B

SMAC→A

Payload

13 MAC IF/SID

A e1/13 (local)

B 300.0.64 (remote) B →

14

S300 →

FabricPath Routing

Table on S100

Switch IF

S10 po10

S20 po20

S30 po30

S40 po40

S200 po10, po20,

po30, po40

S300 po10, po20,

po30, po40

DMAC→B

SMAC→A

Payload

DA→300.0.64

Ftag→1

SA→100.0.12

15

S300 →

FabricPath Routing

Table on S30

Switch IF

… …

S300 po300 16

S300 →

(3) Unicast Data

Hash

DMAC→B

SMAC→A

Payload

DA→300.0.64

Ftag→1

SA→100.0.12

FabricPath

MAC Table on S300

MAC IF/SID

B e2/29 (local)

MAC IF/SID

A S100.0.12 (remote)

B e2/29 (local)

18

FabricPath Routing

Table on S300

Switch IF

… …

S300 Use LID (64)

17

If DMAC is known, then

learn remote MAC

po300

Page 21: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 21

• S100:

S100# sh mac address-table dynamic

Legend:

* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC

age - seconds since last seen,+ - primary entry using vPC Peer-Link

VLAN MAC Address Type age Secure NTFY Ports/SWID.SSID.LID

---------+-----------------+--------+---------+------+----+------------------

* 10 0000.0000.000a dynamic 90 F F Eth1/13

10 0000.0000.000b dynamic 60 F F 300.0.64

S100#

• S300:

S300# sh mac address-table dynamic

Legend:

* - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC

age - seconds since last seen,+ - primary entry using vPC Peer-Link

VLAN MAC Address Type age Secure NTFY Ports/SWID.SSID.LID

---------+-----------------+--------+---------+------+----+------------------

10 0000.0000.000a dynamic 30 F F 100.0.12

* 10 0000.0000.000b dynamic 90 F F Eth2/29

S300#

S100 learns MAC A as

remote entry reached

through S100

Page 22: Обзор технологии Fabric Path

22 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath Technology Overview –

Multicast Forwarding

Page 24: Обзор технологии Fabric Path

24 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – преимущества

Page 25: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 25

• «Растягивание» VLAN между внутри всего облака : L2 связь между двумя любыми устройствами, в независимости от физического расположения

• STP не принимает участие в FP: Отсутствует стандартные «минусы» STP

FabricPath – преимущества (1/3)

POD 1

VLANs 100-199

POD 2 POD 3

VLANs 200-299 VLANs 300-399 VLANs 100-399

PODS 1-3

STP IS-IS

Page 26: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 26

• Простота конфигурации:

• Высокая степень толерантности к топологии:

FabricPath – преимущества (2/3)

N7K(config)# VLAN 1-1000

N7K(config-vlan)# mode fabricpath

N7K(config)# interface ethernet 1/1

N7K(config-if)# switchport mode fabricpath

Page 27: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 27

• Обеспечивает возможность органичного прироста пропускной способности : (минимальное влияние на существующую инфраструктуру)

2-ways ECMP 4-ways ECMP

• Разнообразие решений L2/L3 «границ»

FabricPath – преимущества (3/3)

FP FP

L3

L2/L3 FP

L3

L2/L3

L3

FP

L3

L2/L3 boundary

Routing at Aggregation Centralized Routing Distributed Routing

Page 28: Обзор технологии Fabric Path

28 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – HW & SW

Page 29: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 29

• Fabricpath поддерживается множеством устройств: -NEXUS 7000 с F1 или F2 LC

-NEXUS 5500

-NEXUS 2000 подключенные к NEXUS 5500 или NEXUS 7000/F2

• Nexus 3000 отсутствует аппаратная поддержка FabricPath

FabricPath – требования к HW и SW

Page 30: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 30

Part Number I/O Module CE edge порт(FP режим)

FP core порт

Мин. NX-OS версия

N7K-F132XP-15

✓ ✓ NX-OS 5.1

N7K-F248XP-25

NX-OS 6.0

N7K-F248XT-25

✓ ✓ NX-OS 6.1

Основные требования FPNEXUS 7000

Enhanced Layer 2 License – необходимая тип лицензии

Page 31: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 31

Part Number Chassis CE edge порт(FP режим)

FP core порт Мин.

NX-OS версия

N5K-C5548P-FA

✓ ✓ 5.1(3)N1(1)

N5K-C5548UP-FA ✓

5.1(3)N1(1)

N5K-C5596UP-FA ✓ ✓ 5.1(3)N1(1)

Основные требования FP NEXUS 5500

Обязательным условием есть лицензия

Enhanced Layer 2 License

Page 32: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 32

Part Number Chassis

NEXUS 5500

NX-OS 5.1(3)N1(1)

NEXUS 7000/F2

(NX-OS 6.1)

CE edge порт(FP режим)

FP core порт

N2K-C2148T-1GE ✓

N2K-C2224TP-1GE

✓ ✓ ✓ ✗

N2K-C2248TP-1GE

✓ ✓ ✓ ✗

N2K-C2232PP-10GE

✓ ✓ ✓ ✗

N2K-C2232TM-10GE

✓ ✓ ✓ ✗

Основные требования FP NEXUS 2000 (1/2)

Page 33: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 33

Part Number Chassis NEXUS 5500

NX-OS 5.1(3)N1(1)

NEXUS 7000/F2

(NX-OS 6.1)

CE edge порт(FP режим)

FP core порт

N2K-C2248TP-E ✓

N2K-B22HP-P ✓

Основные требования FP NEXUS 2000 (2/2)

Планируется в

будущих релизах

Page 34: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 34

1 2 FP VLAN 10

VLAN 10

FP VLAN 10

VLAN 10 VLAN 10

FP FP

FabricPath FEX / N5500 поддерживаемые реализации

2

S1 S1

FEX ST FEX:

Straight Through

Server: Active/Active

vPC Port Channeling

3 FP VLAN 10

VLAN 10 VLAN 10

FP

S1 4 FP VLAN 10

VLAN 10 VLAN 10

FP

S1

FEX ST FEX:

Straight Through

Server: Active/Standby

NIC Teaming

FEX A/A FEX:

Active/Active

Server: Active/Standby

NIC Teaming

FEX A/A FEX:

Active/Active

Server: Active/Active

Local Port Channeling

EvPC FEX:

Active/Active

Server: Active/Active

vPC Port Channeling

FEX no vPC

Server:

Active

NIC

vPC+

Page 35: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 35

FabricPath FEX / F2 поддерживаемые реализации

Local

FEX

port-

channel

server:

port-channel

NIC teaming

(active-active)

standby active

server:

active/standby

NIC teaming

1 2

VLAN 10 VLAN 10 VLAN 10

FP VLAN 10 FP

VLAN

10

FP FP

standby active

server:

active/standby

NIC teaming

3 FP

CORE

link

FP

VLAN

10

VLAN 10 VLAN 10

FP

active active

server:

active/active

NIC teaming

4 FP

CORE

link

FP

VLAN

10

VLAN 10 VLAN 10

FP

vPC+

vPC+ c FEX

поддерживается с

6.1(4a)

Page 36: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 36

… …

FP – теперь все вместе Пример топологии

FabricPath

CE

L3

F2

F2

F2

FEX connected directly

to F2 ports

VLANs in FP

mode

F2 F1 F1

F1 F1

FEX connected directly

to F2 ports

F1 F1 F2 F2 F1 F1 F2 F2

F1 F1

5500

M1 M1 M1 M1 F2 F2 F2 F2

S1 S2 S3 S4

S5 S6

S7 S8

S9

S10

5500

Root for

tree #1 F2 Root for

tree #2

L3

Page 37: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 37

FP – теперь все вместе пример конфигурации

S1 (SPINE) S5 (7K LEAF with F2/FEX) S9 (5K LEAF with FEX)

feature-set fabricpath

vlan 1-1000

mode fabricpath

interface port-channel1

switchport mode fabricpath

interface port-channel11

switchport mode fabricpath

fabricpath domain default

root-priority 255

fabricpath switch-id 1

feature-set fabricpath

feature-set fex

vlan 1-1000

mode fabricpath

fex 101

pinning max-links 1

interface port-channel101

switchport mode fex-fabric

fex associate 101

interface port-channel1

switchport mode fabricpath

interface port-channel11

switchport mode fabricpath

fabricpath domain default

root-priority 64

fabricpath switch-id 5

interface Ethernet101/1/1

switchport

switchport access vlan 100

feature-set fabricpath

feature fex

vlan 1-1000

mode fabricpath

fex 101

pinning max-links 1

interface port-channel101

switchport mode fex-fabric

fex associate 101

interface port-channel1

switchport mode fabricpath

interface port-channel11

switchport mode fabricpath

fabricpath domain default

root-priority 64

fabricpath switch-id 9

interface Ethernet101/1/1

switchport

switchport access vlan 100

Page 38: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 38

a) Я нахожу решение достаточно перспективным, и буду рассматривать его в будущем

b) Я считаю, что FabricPath удовлетворяет бизнес требованиям, но инфраструктура требует «массивной подготовки»

c) FabricPath не сможет решить поставленные передо мной задачи

d) В моем конкретном случае я отдаю предпочтение иным L2 технологиям (L2VPN, OTV, etc)

• Какие перспективы FabricPath Вы видите для себя?

Page 39: Обзор технологии Fabric Path

39 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – “VLAN mode”

Page 40: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 40

FabricPath

• M I/O модуль не коммутирует FabricPath трафик

• При конфигурировании FabricPath,

FP Core and CE Edge порты должны быть на F1/F2 модуле или

5500

• FabricPath VLANы могут быть включены на F1/F2 или 5500

• FEX могут иметь настроенные FabricPath VLANы on HIF интерфейсах

S100(config)# vlan 10

S100(config-vlan)# mode ?

ce Classical Ethernet VLAN mode

fabricpath Fabricpath VLAN mode

S100(config-vlan)# mode fabricpath

S100(config-vlan)#

F

F FabricPath

Core порт

Ethernet

Edge порт

FabricPath VLAN

Page 41: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 41

• В противном случае трафик в multidestination trees может быть

блокирован

FabricPath VLAN FP VLAN должны быть настроенны на ВСЕХ коммутаторах

FabricPath

NX(config)# vlan 10-400

NX(config-vlan)# mode fabricpath

NX(config)# vlan 10-400

NX(config-vlan)# mode fabricpath

Page 42: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 42

M1 M1 F1/2

VLAN 10 VLAN 10

mode FP

VLAN 10

mode FP

FP F1/2 F1/2 F1/2

FabricPath VLAN Подключение M1 или M1/F1 к FP облаку

Используйте

loopback кабель от

M1 или M1/F1 к FP

LEAF коммутатору

M1

VLAN 10 VLAN 10

mode FP

VLAN 10

mode FP

FP F1 F1/2 F1/2 F1/2 F1/2

M1

VLAN 10 VLAN 10

mode FP

VLAN 10

mode FP

FP F1 F1/2 F1/2 F1/2 F1/2 F1

CE link

loopback

cable

L2 TRUNK

or

switchport

access

Page 43: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 43

FabricPath VLAN Пример конфигурации

• Настройте FP VLAN на всех коммутаторах в FP

vlan 10-100 mode fabricpath

• Ограничьте список VLAN на CE EDGE портах, настроенных как trunk

int eth1/1 switchport mode trunk switchport trunk allowed vlan 100-1000

• VLAN prunning на FP портах происходит автоматически

Int eth1/2 switchport mode fabricpath

Page 44: Обзор технологии Fabric Path

44 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – Root Priorty

Page 45: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 45

FabricPath root-priority

• Почему важно контролировать размещение корня: multidestination tree #1 (broadcast / unknown unicast / multicast) multidestination tree #2 (multicast)

• SPINE коммутаторы назначают primary and secondary root

APULIA-1-FP_AGG1(config)# fabricpath domain default APULIA-1-FP_AGG1(config-fabricpath-isis)# root-priority ? <1-255> Root priority value per topology *Default value is 64

SPINE switch 1

SPINE switch 2 SPINE switch 3

fabricpath domain default

root-priority 255

fabricpath domain default

root-priority 254

fabricpath domain default

root-priority 253

Page 46: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 46

sh fabricpath isis switch-id

Fabricpath IS-IS domain: default

Fabricpath IS-IS Switch-ID Database

Legend: C - Confirmed, T - tentative, W - swap

S - sticky, E - Emulated Switch

'*' - this system

System-ID Primary Secondary Reachable Bcast-Priority

MT-0

0005.73b1.f4fc 11 [C] 0[C] Yes 64 [S]

0005.73b2.1541 12 [C] 0[C] Yes 64 [S]

0022.5579.aac1 6 [C] 0[C] Yes 64 [S]

0022.5579.aac2 2 [C] 0[C] Yes 252 [S]

0022.5579.aac3* 13 [C] 0[C] Yes 64 [S]

0022.5579.aac4 4 [C] 0[C] Yes 64 [S]

0022.5579.aac4 101 [C] 0[C] Yes 0 [E]

0022.5579.ab41 5 [C] 0[C] Yes 253 [S]

0022.5579.ab42 100 [C] 0[C] Yes 0 [E]

0022.5579.ab42 1 [C] 0[C] Yes 255 [S]

0022.5579.ab44 101 [C] 0[C] Yes 0 [E]

0022.5579.ab44 3 [C] 0[C] Yes 254 [S]

• Show command to check root-priority on all switches in the FabricPath Fabric :

FabricPath root-priority

Page 47: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 47

Switch-id 121

Switch-ID 111 Switch-ID 112 Switch-ID 113

Switch-id 122

Root для FTAG 1 Root для FTAG 2

FabricPath root-priority multidestination trees и FTAG

FTAG : •Для multidestination трафика (broadcast, multicast, unknown unicast), определяет какое дерево использовать

Switch-id 121

121# show fabricpath isis topology summary

Fabricpath IS-IS domain: default FabricPath IS-IS Topology

Summary

MT-0

Configured interfaces: port-channel1 port-channel13 port-

channel31 port-channel51

Number of trees: 2

Tree id: 1, ftag: 1 [transit-traffic-only], root system:

0022.5579.ab42, 121

Tree id: 2, ftag: 2, root system: 0022.5579.ab44, 122

Root-

priority

255

Root-

priority

254

Page 48: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 48

Корень дерева выбирается следующим образом:

Коммутатор (switch1) с лучшим приоритетом становиться корнем для #1.

Коммутатор (switch2) с с следующим лучшим приоритетом становиться корнем для #2.

Если switch1 недоступен, switch2 становится корнем для дерева #1

Корень для #2 будет выбираться исходя из:

1/ Следующий лучший приоритет

2/ Наивысший System ID, далее наибольший Switch ID

При потере корня #1 или #2, FP будет сходиться в среднем 500мс

FabricPath root-priority А что если?

Page 49: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 49

FabricPath root-priority Пример конфигурации

• Use SPINE switches for primary and secondary root (and ternary root)

Spine 1 : fabricpath domain default root-priority 255

Spine 2 : fabricpath domain default root-priority 254

Spine 3 : fabricpath domain default root-priority 253

Page 50: Обзор технологии Fabric Path

50 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – взаимодействие с STP

Page 51: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 51

FabricPath

• FabricPath выглядит как единый коммутатор:

• Посылая одинаковые STP BPDU на все пограничные порты

• Важно, чтобы FP облако выступало в роли STP корня (иначе edge порты будут блокированы)

• BPDU не передаются сквозь фабрику

• Опционально TCN могут передаваться по фабрике

Classical Ethernet (STP)

✖ STP Domain 1

STP Domain 2

CE Edge Ports

FabricPath (no STP)

BPDU BPDU

STP Domain

FabricPath и взаимодействие с STP

Page 52: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 52

FabricPath

• Каждый коммутатор использует одинаковый bridge ID (C84C.75FA.6000), который не может быть изменен

• Пограничные коммутаторы должны выступать в роли корня для всех STP доменов подключенных к FP.

• Все FabricPath Layer 2 gateway подключенные к единой FabricPath сети должны иметь одинаковый приоритет.

Classical Ethernet (STP)

✖ STP Domain 1

STP Domain 2

CE Edge Ports

FabricPath (no STP)

BPDU BPDU

STP Domain

FabricPath и взаимодействие с STP Layer 2 gateways

Layer 2

gateway

switch Layer 2

gateway

switch

Page 53: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 53

FabricPath

Classical Ethernet (STP)

STP Domain 1

STP Domain 2

CE Edge Ports

FabricPath (no STP)

BPDU BPDU

STP Domain

FabricPath STP interaction TCN

Layer 2

gateway

switch

S1 and S2

(Layer 2 GW switch)

vlan 10-1000

mode fabricpath

spanning-tree domain 1

spanning-tree vlan 10,101,600-610 priority 8192

S1 S2 S5

S5

(Layer 2 GW switch)

vlan 10-1000

mode fabricpath

spanning-tree domain 2

spanning-tree vlan 10,101,600-610 priority 8192

Layer 2

gateway

switch

Page 54: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 54

FabricPath

Classical Ethernet (STP)

STP Domain 1 STP Domain 2

FabricPath (no STP)

FabricPath STP interaction TCN propagation

S1 S2 S5 S6

TC

N T

CN

TCN TCN T

CN

✖ 1

2

3

4

No TCN

propagation 5

Page 55: Обзор технологии Fabric Path

55 © 2011 Cisco and/or its affiliates. All rights reserved.

FabricPath – vPC+ vPC+ на SPINE уровне

vPC+ на LEAF уровне

Page 56: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 56

• vPC+ рекомендуется в 2х случаях:

«Двойное» включение хоста к FabricPath (aka VPC)

Использование Active/Active HSRP сценария HSRP A/A требует только VPC+ peer-link

FabricPath

A

s3 s8 s7 s4

VLAN X

VLAN Y

VLAN Z

FabricPath - vPC+

vPC

+

vPC

+

vPC

+

1

2

1

2

B

Page 57: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 57

• VPC+ коммутаторы используют “виртуальный”

FabricPath switch ID

• MAC за VPC+ port-channels выглядят как “подключенные” виртуальному коммутатору,

• В VPC+ все VLAN должны быть в FP режиме

F F

VPC+ F

F F

S1 S2

F

F F

VPC+ F

F F

S1 S2

F

Хост A→S4→L1,L2 S3

A

A

L1 L2

S3

L1 L2

S4

Physical

Logical

Вирт.“Switch 4” становится

исходящим для

хоста A а FP домене

→ FabricPath

→ CE FabricPath - vPC+ vPC+ для подключения хоста

S1 S2

feature vpc

vlan 1-23

mode fabricpath

vpc domain 100

peer-keepalive destination

172.26.246.86 source 172.26.246.85

fabricpath switch-id 4

interface port-channel100

switchport mode fabricpath

vpc peer-link

interface port-channel1

vpc 1

fabricpath domain default

fabricpath switch-id 1

feature vpc

vlan 1-23

mode fabricpath

vpc domain 100

peer-keepalive destination

172.26.246.85 source 172.26.246.86

fabricpath switch-id 4

interface port-channel100

switchport mode fabricpath

vpc peer-link

interface port-channel1

vpc 1

fabricpath domain default

fabricpath switch-id 2

Page 58: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 58

S1 S2

feature vpc

vlan 1-23

mode fabricpath

vpc domain 100

peer-keepalive destination

172.26.246.86 source 172.26.246.85

fabricpath switch-id 4

interface port-channel100

vpc peer-link

switchport mode fabricpath

fabricpath domain default

fabricpath switch-id 1

interface Vlan10

no shutdown

ip address 10.10.10.1/24

hsrp 10

ip 10.10.10.254

feature vpc

vlan 1-23

mode fabricpath

vpc domain 100

peer-keepalive destination

172.26.246.85 source 172.26.246.86

fabricpath switch-id 4

interface port-channel100

vpc peer-link

switchport mode fabricpath

fabricpath domain default

fabricpath switch-id 2

interface Vlan10

no shutdown

ip address 10.10.10.2/24

hsrp 10

ip 10.10.10.254

F F

VPC+ F

F F

S1 S2

F

A

S3

L1 L2

→ FabricPath

→ CE FabricPath - vPC+ vPC+ для Active/Active HSRP

S1

sh mac address-table vlan 10

S2

sh mac address-table vlan 10

G 10 0000.0c07.ac0a static - F F sup-eth1(R)

* 10 0022.5579.aac2 static - F F 2.0.1054

G 10 0022.5579.ab42 static - F F sup-eth1(R)

G 10 0000.0c07.ac0a static - F F 1.0.1054(R)

G 10 0022.5579.aac2 static - F F sup-eth1(R)

* 10 0022.5579.ab42 static - F F 1.0.1054

HSRP

10

vMAC

S2 SVI 10

MAC

S1 SVI

10 MAC

M M

Page 59: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 59

FabricPath - vPC+ vPC+ и требования к аппаратной части

Part Number I/O Module vPC+

peer-link vPC+ leg

N7K-F132XP-15 ✓ ✓

N7K-F248XP-25

N7K-F248XT-25 ✓ ✓ FEX with F2 LC

✗ ✓

Part Number Chassis vPC+

peer-link vPC+ leg

N5K-C5548UP-FA ✓ ✓

N5K-C5596UP-FA

✓ ✓

FEX with 5500

✗ ✓

Page 60: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 60

vPC Peer-link

S1 S2

vPC+ Primary vPC+ Secondary

F1 F1

vPC+

FabricPath - vPC+ vPC+ - supported topologies (without FEX)

F1

F1

F1

F1

vPC Peer-link

S1 S2

vPC+ Primary vPC+ Secondary

F2 F2

vPC+

F2

F2

F2

F2

vPC Peer-link

S1 S2

vPC+ Primary vPC+ Secondary

F1 F2

vPC+

F1

F1

F2

F2

vPC Peer-link

S1 S2

vPC+ Primary vPC+ Secondary

vPC+

F1

F1

F1

F1

M1 M1

F1 – F1 F2 – F2

F1 – F2 F1 – F1

Page 61: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 61

• При vPC+ HSRP MAC объявляется как подключенные к EmulatedSwitchID

• С точки зрения data-plane – оба устройства являются «активными»

• В отношении control-plane по сущности HSRP по прежнему Active/Standby

Active HSRP Active HSRP

Switch-id 121

Switch-id 122

Switch-ID 113

Switch-ID 111

Switch-ID 112

vPC+

Peer-link on F1/F2

Peer-link должен быть FabricPath линком

FabricPath - vPC+ at SPINE layer vPC+ at SPINE layer

Page 62: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 62

• FP Conversational learning;

• MAC на SPINE FP устройствах

• HSRP Anycast

• FP Multicast

• …

Page 63: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 63

a) OTV как еще одна альтернатива DCI.

b) VPC и аспекты его реализации

c) QoS на Nexus 5000 и 2000

В рамках следующего вебинарa вам будет интересно узнать больше о:

Page 64: Обзор технологии Fabric Path

64 © 2011 Cisco and/or its affiliates. All rights reserved.

Эксперт ответит на некоторые Ваши вопросы. Используйте Q&A панель, чтобы задать еще вопросы

Page 65: Обзор технологии Fabric Path

65 © 2011 Cisco and/or its affiliates. All rights reserved.

Получить дополнительную информацию, а также задать вопросы экспертам в рамках данной темы вы можете в течение двух недель, на странице, доступной по ссылке

https://supportforums.cisco.com/community/russian/expert-corner

Вы можете получить видеозапись данного семинара и текст сессии Q&A в течение ближайших 5 дней по следующей ссылке https://supportforums.cisco.com/community/russian/expert-corner/webcast

Page 66: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 66

на Русском

Во вторник, 21 января, в

12.00 Moscow Time

Присоединяйтесь к эксперту Cisco Олегу Типисову

Во время презентации эксперт Cisco TAC Олег Типисов приведет примеры использования различных возможностей и диагностических средств Cisco ASA для решения проблем, возникающих при передаче трафика, а также проблем производительности и исчерпания ресурсов. Также будут даны рекомендации, позволяющие избежать наиболее часто встречающихся при эксплуатации проблем, связанных с исчерпанием ресурсов.

Регистрируйтесь на вебкаст по ссылке:

http://tools.cisco.com/gems/cust/customerSite.do?METHOD=E&LANGUAGE_ID=R&SEMINAR_CODE=S19609&PRIORITY_CODE

Тема: Использование packet-tracer, capture и других

утилит Cisco ASA для диагностики сетей

Page 67: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 67

in English

Во вторник, 7 января, в 10:00 Moscow Time

6:00 LondonTime (BST UTC +1)

7:00 CEST Paris (CEST UTC +2)

Присоединяйтесь к эксперту Cisco Akhil Behl

Во время презентации эксперт Cisco TAC Akhil Behl расскажет о различных типах сертификатов, доступных на Cisco Unified Communications Manager. Эта сессия будет построена на концепции Cisco для совместной работы PKI и Cisco Unified Communications Manager.

Регистрируйтесь на вебкаст по ссылке:

http://tools.cisco.com/gems/cust/customerSite.do?METHOD=E&LANGUAGE_ID=E&SEMINAR_CODE=S19542&PRIORITY_CODE

Тема: PowerVu Системы управления сетями

Page 68: Обзор технологии Fabric Path

© 2011 Cisco and/or its affiliates. All rights reserved. 68

https://supportforms.cisco.com/community/russian

http://www.facebook.com/CiscoRu

http://twitter.com/CiscoRussia

http://www.youtube.com/user/CiscoRussiaMedia

http://itunes.apple.com/us/app/cisco-technical-support/id398104252?mt=8

http://www.linkedin.com/groups/CSC-Cisco-Support-Community-3210019

Newsletter Subscription: https://tools.cisco.com/gdrp/coiga/showsurvey.do?surveyCode=589&keyCode=146298_2&P

HYSICAL%20FULFILLMENT%20Y/N=NO&SUBSCRIPTION%20CENTER=YES

Page 69: Обзор технологии Fabric Path

Спасибо за Ваше время

Пожалуйста, участвуйте в опросе

Page 70: Обзор технологии Fabric Path

Thank you.